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Overview

This article will show you the different ways you can find possible duplicate records (Voters/Donors/Contacts) in your database. Even the most
conscientious organizations will get duplicate records from time to time due to uncontrollable factors.

Outline

#1 Find Possible Duplicates

#2 Assign Possible Duplicates to an Attribute En Masse
#3 Related Resources

#1 Find Possible Duplicates
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Navigate to your contact list (Voters/Donors/Contacts). In this example | used a nonprofit database where we renamed Donors to People and Orgs.
Click here to learn how to customize labels in your database.

a5 Help

Application Menu

=

Tasks
- § Calendar/Tasks

--[&[] Minnesata \oter List

----- Addresses

----- Households

--{&f Donor Relationships
EEI--% Denors, Other Formats
(-4 Contributions/Pledges
I:I;":; Product Sales

<> Logs

H- Email Campaigns
H-gu Financial
&g System Manager

Load up a list of records you want to search through for duplicates. If your database has a large amount of records i.e. 100k — 1Milliion+ you may
want to run this process in different chunks. In my example | loaded all 10,496 records.
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<3 Search ¥, Reset |4k New [S|E 05 || OF (| File » Edit + | ) |&pInclude Other | Donors |
Q

Favortes | General | Address | Household | Attribute | Canvass | Contribute | Pledge | Event | Log | Admin | saL |
Name | Phone | E-Mail | Email Links | Profile | Work | Demographics | User, Text | User, Dates | User, Decimal | Gther |

Q
Individual

Caorporation
Foundation

Last Mame: = Prior Last Mame:

First/'Org Mame: « Title:
Middle Mame: -  Suffix:

Mickname:

Donors List Load

Records to Load
|Seard1 found 10,456 records. Of these, load:

SE Edit | % Include % Exclude | Sort B Formd © Top @Al
| 2

10496 records found. Staring load dialog. ..

Last " Progress

I Title  pome |'

\Waiting for user input...

Click [File] > Utilities > Find Possible Duplicates
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< Search ¥, Reset |dp New |S|E = | ) oF ¢ |File +| Edit ~ | ) | §gInclude Other | Donors
QJ €p Communications »

Favorites | General | Address | Household | Atiribute | Canvass | B3 _Reporting * | L admin [sqr |

MName |F'hune | E-Mail I Emciblie I Profile |Wnrk I Demo ﬁh ilities 2 k 3 Export

QIW
Impert...
Qo

Delete Selected Records...

Individual Last Mame: Prior Last Name:

Corporation First'Org Name: - Title:
Middle Name: - Suffix:

Merge...
Find possible duplicates... 3]

Foundation

Split Couples into Separate Donors...

Sortin housl Find possible duplicates i

S

Mickname:

The ="tie breaker” columns include:
- Middle Name
- Birthdates
- SOS (Secretary of State Number)
- Address
- Last Name
- First Name
Example: If you select only name and address, people with different middle names will be listed as a possible duplicates.
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Set Column to Search For Possible Duplicates @

Tie Breaker Options

Trail Blazer's merge tools are based on exact matches of name and address and
bithday etc. Howewver, sometimes the addresses are not exactly the same.

Comparing the addresses below you can see that they are the same, but our nomal
merging process would not see them as indertical.

123 Main Street, Apt 101
123 Main St Apt 101

The default tie breaker process includes last name, first name, and the first 8
characters of the address. You may optionally include middle name, birthday and
vaoter election board Woter Mumber to your tie breaker criteria.

\when evaluating for duplicates... |

...include middle name.
...include birthdays.
..include election board voter number (505 #).

Mumber of characters of the address to include (default=8).
Mumber of characters of the last name to include (default=255).
Mumber of characters of the first name to include (default=255).

[F[~0 0 0

ALE L ALE (AR

© o] [@ el |

You can change around the options to fit your needs — every time you run the process you will need to start with a new contact list.

If you lower the numbers for characters to include in the address and name you will likely find more duplicates but they could be false positives.
For instance it could be a Sr. and Jr. living at the same address with similar names.
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In my example | lowered the 3 thresholds to 8, click [OK] when you’re ready to run the process.

Set Column to Search For Possible Duplicates

Tie Breaker Options

Trail Blazer's merge tools are based on exact matches of name and address and
bithday etc. However, sometimes the addresses are not exactly the same.

Comparing the addresses below you can see that they are the same, but our nomal
merging process would not see them as indertical.

123 Main Street, Apt 101
123 Main St Apt 101

The default tie breaker process includes last name, first name, and the first 8
characters of the address. You may optionally include middle name, bithday and
voter election board Voter Mumber to your tie breaker criteria.

When evaluating for duplicates. .
[] ...include middle name.

..include birthdays.
..include election board voter number (505 #).

Mumber of characters of the address to include (default=8).
Mumber of characters of the last name to include (default=255).
Mumber of characters of the first name to include (default=255).

@ ok |[|@cancel |

Trail Blazer will display a progress bar, if you’re working with millions of records it will of course take some time and you may want to launch a
separate session of TBZ.
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Progress @

Progress

Additional data columns for 500 of 10436 records receved.

Cancel

Once complete it will prompt you with the results and a recommendation to assign this list an attribute of “Possible Duplicates”. Click here to learn
how to set attributes en masse.

In my example | had 36 possible duplicates from my entire list of about 10,000 records.

KNOWLEDGE BASE www.trailblz.com/kb 7



http://www.trailblz.com/kb
http://trailblz.com/kb/?action=view&kb=86&cat=1

& TrailBlazer

Organize. Leverage. Succesd. Flnd POSSible Duplicates

ADDITIONAL INFORMATION = = |

36 possible duplicates have been found and are now displayed. It is HIGHLY

s recornmended that you assign these to an attribute of your choosing so you may
return to this list pericdically as needed. If you close this list, you will need to
re-run this analysis again to regenerate the list.

Foer rore information about Group Management see the Group Management
instructional videos at http://trailblz.com/Support/Learning/VideosTraining.aspx.

You can copy the contents of this message by pressing Ctrl+C on your keyboard.

Click [OK] to finish.

Here’s a sample snapshot of my duplicates:
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Possible Duplicates

EE Edit | % Include % Exclude B Sort B Format maExport &Print |§| Summary [D B = i

Donors [ 36 records found |

Last Z
Ind 1D vl First Name - City State &fde

12366 || Clark I[5903 Tree Fam Rd [[Eden Praine [mn [55347 [[]]
Clar i 5903 Tree Farm Rd Eden Praire | MM hh347

Swanberg 7969 Island Rd Eden Praiie | MN 55347
Swanberg 7969 Island Rd Eden Praire | MN 5h47
Burton i 706 Bellows St Sairt Paul MN hh107

Burton i 706 Bellows 5t Saint Paul MM 56107
Markovic i 657 Geonge Kennedy Belle River ONT... | NOR1AD

Markzovic i 657 George Kennedy Belle River ONT... [ NOR1AD
McDem... | Patrick 6470 125th 5t W Apple Valley | MN 55124
McDem... | Patrick 6470 125th 5t W Apple Valley | MN 55124
Alden John 6217 France Ave 5 Edina MN 5b410
Alden John 6217 France fAve S Edina MN
Martola Cosimo 5hbz st Mabile
Martola Cosima 58bz st Mabile

Foster Michael 5061 Golden Valley Rd || Golden Valley
Foster Michael 5061 Golden Valley Rd || Golden Valley
Klamm Daniel 4130 140th 5t NE Prior Lake
Klamm i 4130 140th 5t NE Prior Lake

EEEEEEEEEEEEEEEE

From here it’s at your discretion how to proceed. Some options would include:
- Delete out the duplicate records
- Merge contact records

- Perform drag-and-drop merges to combine information into a single record
- Run automatic merging (requires records match exactly for merge to work)
- Assign the list to an attribute such as “Possible Duplicates”
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In my example | chose to assign these records to an attribute called “Possible Dupes” en masse — the next section walks through that process.

#2 Assign Possible Duplicates to an Attribute En Masse

After you’ve got the list of possible duplicates on your screen click [Edit] > Set > Set Attributes
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g Search . Reset | ok New |/= o | L) ¥ @ | File ~|Edit »|| «/ | @@ Include Other | Donors
Q G s 2 B
ol R

Fia

Set Attributes... 3 |
Set Events...

0

| Favorites | General | Address | Household | Attribute | Canvass | Contribut

Azsign
Include | EBxclude
Q

RS RRS | KRS

Set Fields... Set or Clear Attributes from Donors ]

Infer/Set Gender

A

Make Doner Type Ind if not set

In precisehy
@ In at least

In range

In all

|1]' —|to |ﬂ' :|

OO0 000 OO0 @O0 GO0 |G

RS AR

Set Doner Type..
Organizational Duties

Organizers

Social Metwork Pref
Social Metwarking

of U selected - Social Metworking - CST
Snrial Metwndrinn F

g

Create Lawn Sign Records...

=8 Edi la i i = Pi
I=EEn:.Irt % Include % Exclude ﬁﬁur’c @Furmat -ﬁE}[F}DI’t &Prmt IE] Summary D] E PI"-"Dt |

36 Possible Donor Duplicates Found

Click the Assign selected attributes to donors radio button and check the box of the attribute you want to set. *Attribute would have needed to be
created previously, click here to learn how.
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@ Set Attributes

@ Assign selected
= gttributes to donors

 Remove selected
() attribute assignments
from donors

=] Atributes

@0
&0

&
&0
&0
&0
&0
&0
-

Contact Method
DB Cleanup

Possible Dupes
donors social net pref
Group
Membership
Mot (items in this folder are hidden from nommal 1
Organization
Organizational Duties
Organizers
Social Network Pref
Social Networking
Social Networking - C5T
Social Networking 2
Source
Volunteer

Click [OK] to proceed. Click [OK] again after prompted with the security warning.
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%) Set Attributes

@) Pssign selected =] Attributes
= attributes to donors #-7] Contact Method

EI DB Cleanup

Remove selected _ _
(7 attribute assignments - Possible Dupes

from donors w-{_|  donors social net pref
.. Group

@-{7]  Membership
| Mot (items in this folder are hidden from nomal
=M [ o S——

[ Warning — [

ii 36 Donors may be updated. Do you wish to proceed?

_

Cancel |

| 3

oK ”@C‘am' l

You'll be notified when the process is complete. You can now search by that attribute in the future.
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) Set Attributes

5 Assign selected =]  Attributes
® Sttributes to donors @] Contact Method
-] DB Cleanup

Remove selected EI = ]
#) ofis ; : Possible Dupes
(" attribute assignments -

From donaors : donors social net pref
-- Membership
-- Mot (items in this folder are hidden from nommal +

@ 36 donors processed.
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Q

< Search . Reset |4k New |S|E = | ) O @ | File + Edit » | & |§pInclude Other | Donors |

| Favorites | General | Address | Household | &% Attribute | Canvass | Contribute | Pledge | Event | Log | Admin | saL |

A nclude | Exclude

Q

() In precisety
@ In at least
7 In range
i nal

Attribute

E-{=r Attributes

1 Contact Method

N e

of 1 selected

/!

[ donors social net pref

1| =0 & O =

i Groon

=8 Edi ry i i =l Pi
8 Edit | % Include % Exclude B Sort B Format | EEupurt &Prmt | Surnrmary [D E |Pn.rut |

Donors [ 36 recornds found |
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009

Trail Blazer
- YouTube Channel

- Knowledge Base Articles
- 3rd Party Resources

#3 Related Resources

Article: Regular Maintenance — Best Practices

Article: Merge Contact Records

Video: How to Manage Duplicates

Video: Attributes — Assign en masse

3" Party Learning Resource: How to Find Duplicates in Excel

Trail Blazer Live Support

© Phone: 1-866-909-8700
® Email: support@trailblz.com

Kl Facebook: https://www.facebook.com/pages/Trail-Blazer-Software/64872951180
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B Twitter: https://twitter.com/trailblazersoft

*As a policy we require that you have taken Trail Blazer’s intro training class before calling or emailing tech support. Click Here to view our
calendar for upcoming classes and events. After signing up you will receive instructions for how to log into the interactive online webinar.

*This service is included in your contract.
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